Desktop Client Captcha failures
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 19:45 UTC
Update
We are continuing to investigate this issue.
Posted Jun 23, 2020 - 17:37 UTC
Investigating
We are aware of an issue preventing users from logging into the desktop client. Current workaround would be to use the www.faceit.com to login to your account and play.
Posted Jun 23, 2020 - 17:33 UTC
This incident affected: Login.